1. You can now buy finished microcontroller project from us, Check out the Store for the complete list of projects.
  2. Need a custom project, Send us some details about your project. So that we can quote the price for it.

Strange problem with 8051uc 16x2 lcd in 4bit mode.

Discussion in 'Project Doubts' started by pratikshinde, Jul 19, 2012.

  1. pratikshinde

    pratikshinde New Member

    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    I have made a custom design for 8051 board, I have successfully interfaced 16x2 lcd with 8051(P89V51RD2) in 4bit mode, which is connected to PORT0
    P0.0 RS
    P0.1 RW
    P0.2 EN
    and P0.4 to P0.7 data lines, which was working fine.


    Now I have made 2nd revision of that board in which the lcd is not working, but if I connect same LCD to PORT1 its working fine with same code,
    there are no major changes in schematic except addition of two components, a switch and a capacitor. I have checked for continuity with Pull Up resistors
    and everything is fine. even I tried with 10kΩ and 4.7kΩ resistor networks as pull ups but did not work.


    Any help in this regard will be highly appreciated!

    Thanks
  2. Binu

    Binu Administrator

    Likes Received:
    147
    Trophy Points:
    63
    Sure the problem should be in your code or schematic.

    Check the PINs correctly, also the code for port deceleration.

    You may use the port number P1.x in any of your new code.
  3. pratikshinde

    pratikshinde New Member

    Likes Received:
    0
    Trophy Points:
    0
    schematic

    I am attaching schematic

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      15.5 KB
      Views:
      8
Loading...
: 4bit mode, 8051, lcd, port0

Share This Page