1. You can now buy finished microcontroller project from us, Check out the Store for the complete list of projects.
  2. Need a custom project, Send us some details about your project. So that we can quote the price for it.

InfraRed Remote Switch (6 devices + 1 fan) -AT89S51

Discussion in 'Doubts in My Projects' started by Binu, Jun 2, 2007.

  1. vaibhav6820

    vaibhav6820 New Member

    Likes Received:
    0
    Trophy Points:
    0
    dear sir,

    when i send command form remote transmitter how the system will learn the perticular command is for perticular output by using switch how can i store and also tell me tsop 1738 or tsop1736 which is suitable for this project

    regards,

    vaibhav

    vaibhav ingale
  2. Binu

    Binu Administrator

    Likes Received:
    144
    Trophy Points:
    63
  3. vaibhav6820

    vaibhav6820 New Member

    Likes Received:
    0
    Trophy Points:
    0
    Happy Diwali

    regards,

    vaibhav:)

    vaibhav ingale
  4. vaibhav6820

    vaibhav6820 New Member

    Likes Received:
    0
    Trophy Points:
    0
    dear sir,

    you have not reply me about my codes(pp1.zip) i have also problem please tell me how i connect the switch to the microcontroller

    regards,

    vaibhav:)

    vaibhav ingale
  5. JOHNHONAI

    JOHNHONAI New Member

    Likes Received:
    0
    Trophy Points:
    0
    I want point out some corrections on your remote control circuit.
    1.in the circuit pin 29 is connected to fan; but actually in the code pin 32 is used.
    2.you have not mentioned in the circuit weather the 7 segment is common anode or cathode...also the sequence is not mentioned... i found it to be common anode..and the sequence starts from 39-A,38-B....so on
    3.The moc3011 connections need to be checked...actually pin 4 of ic is to be connected to gate and pin 6 to the supply..so toggle the pins on the circuit...
  6. JOHNHONAI

    JOHNHONAI New Member

    Likes Received:
    0
    Trophy Points:
    0
    i have some problems in controlling the fan.....the 7 segment shows the speed but no output through the pin 32(as in the code)...i used an led to check the output at pin 32..once it worked and went off...the switching of devices are working perfectly...but problem with fan control....can you please mail me the updated circuit and code...my id johnjafferjaffer@gmail.com
  7. Binu

    Binu Administrator

    Likes Received:
    144
    Trophy Points:
    63
    1. Yes you are correct, i have changed the circuit now
    2. I have mentioned it as CAD
    3. The circuit works fine with pin4 to the supply and 6 to gate.

    Check the zero crossing detector circuit regarding the fan speed control.

    J.Binu
    Click here to Assemble your 8051 Codes online
  8. JOHNHONAI

    JOHNHONAI New Member

    Likes Received:
    0
    Trophy Points:
    0
    u are really great...i really appreciate your interest in replying to the posts in such a short notice...i want to ask you one thing more....
    1.Can i burn the code to 8051 and use.....what changes i have to make....since 8051 is readily available for me..
    2.i checked the zerocrossing detector it works fine but still no control of fan....is ther any mistake in the values of resistance ....
  9. Binu

    Binu Administrator

    Likes Received:
    144
    Trophy Points:
    63
  10. JOHNHONAI

    JOHNHONAI New Member

    Likes Received:
    0
    Trophy Points:
    0
    Thanks for your reply.....i am using AT89c51....i also tried the program given in page 2(pp.asm)....its is also not working for me...
    1.you have modified the circuit and added an led and switch but is there something to change in code...
    2.the devices goes off on port 2 when power resumes....then i had to make it on....but the speed on 7 segment remains the same...
    3.I checked the zerocrossing on CRO its working fine...but still no fan control...I even changed the LM358...
    please do reply.....
Loading...

Share This Page